经验首页 前端设计 程序设计 Java相关 移动开发 数据库/运维 软件/图像 大数据/云计算 其他经验
当前位置:技术经验 » 大数据/云/AI » SAS » 查看文章
vue中使用sass及解决sass-loader版本过高导致的编译错误问题
来源:jb51  时间:2022/4/11 12:27:19  对本文有异议

使用sass及解决sass-loader版本过高导致编译错误

安装依赖包

安装node-sass、sass-loader和style-loader:

npm i node-sass sass-loader style-loader -D

使用

<style scoped lang="scss">
</style>

解决编译错误

操作以上步骤后,运行,发现报错。原因是sass-loader版本过高,node-sass和sass-loader不兼容。解决办法:卸载当前版本的sass-loader,安装指定版本:

npm uninstall sass-loader ?//卸载
npm install sass-loader@7.3.0 ?//安装指定版本

安装sass(规避因版本过高报错)

安装的两个命令

npm install sass-loader@7.3.1 --save-dev
npm install --save-dev node-sass

配置文件

打开build文件夹下的webpack.base.conf.js

找到module.exports里的module,在rules里添加下面的配置:

{
? test: /\.sass$/,
? loaders: ['style', 'css', 'sass']
}

样式标签更改

<style lang="scss">

然后 npm run dev 重启一下

以上为个人经验,希望能给大家一个参考,也希望大家多多支持w3xue。 

 友情链接: NPS